Friday, September 29, 2006

Evaluating Windows Vista RC1 Build 5600

Windows Vista RC1 ScreenshotIt's been 3 weeks evaluating Windows Vista RC1 and I'm actually quite happy with it — so far at least. I have seen early builds of Vista in demos, but this is the first time I'm testing Vista on my own machine.

Getting the ISO

Downloading the 2GB+ ISO image took around 12 hours on my local Internet connection. After verifying the integrity of the downloaded file via a MD5 checksum checker, it was straight to burning to DVD. At a burn rate of a little over 2X on a DVD+RW media, it took around 15 minutes for the burning process to complete.


This is the one thing that really had taken me by surprise. With such a mammoth OS, installation was actually easy and fast. With XP Professional x64, installation took a solid one hour; but with Vista, all it takes was 30 minutes on the same machine — a year-old AMD Athlon 64 3000+ 1GB machine, with a Windows Experience Index of 3.3. Windows Experience Index is Vista's built-in machine performance benchmarker.

I used the Vista Beta 2 product key from the DVD set I got at the recent Tech.Ed conference to activate Vista. [This was before the Vista Customer Preview Program (CPP) was re-open to the public.] The Vista version installed is Vista Ultimate.

First View of Vista

This is probably the best part. The new glass-effect UI is indeed a visual feast! I mean I've seen demos and all, but to experience it oneself is another thing. I now have a reason to put my ATI Radeon DirectX 9 128MB card to good use; you see, I'm not really a gamer. Navigating around menus, closing and opening windows actually felt surprisingly snappy. Even the 3D animation felt silky smooth.

Drilling Further into Vista

Except for the RAID component, Vista had drivers for the rest of my PC components. I downloaded the beta version of the ATI Radeon driver from ATI's website to see if the native driver performs better than the default one. Well, to be frank, I can't tell the difference. Maybe, it is a little faster but that's probably a psychological thing. Other than that, my pendrive, MSI Bluetooth adapter, and Creative Webcam Go webcam all worked fine. For my webcam, I installed the Creative WDM driver for XP and it actually worked! I've not tested my USB laser printer though, even though there's a driver installed for it.

Running Applications on Vista

Well, I'm not going to say much about Vista's applications. Some highlights: Instant search from almost anywhere, better photo management, direct to DVD burning, IE7, Windows Media Player 11, to name a few. You can read all the features here.

On third-party apps, I installed Adobe Acrobat Reader, ICQ, Paint.NET, Google Earth and all of the apps worked fine. I've not tested my favorite software dev tool (Visual Studio 2005); from what I heard, there might be issues with debugging and the upcoming VS 2005 SP1 should solve these issues. I shall be testing Microsoft Office 2007 on Vista soon; a Technical Refresh must to be installed to run Office 2007 Beta 2 on Vista RC1.

RC1 (Driver?) Quirks

There are a few operational quirks that I've come to observe:

  • At times, after returning from hibernation or sleep, the screen resolution and the single/dual monitor setting did not stay at the previous setting.
  • There is a case of stuttering with the sound.

Just nit-picking: Fonts used in some Vista core apps are not consistent — still a mix of old and new. In addition, some of the icons still spot the classic Windows icons e.g. WordPad toolbar. I suppose that will be fixed in the RTM version.

To sum it all...

The core of RC1 build 5600 is quite stable. I haven't had a fatal crash yet. It has the looks, the features and functionality, and to my surprise, the speed. Okay, okay, it feels much more secure too. On the flip side, it's definitely not production stuff —yet— due to some of the quirks I've pointed out; but hey, it's pre-RTM software after all!

No comments: